Home > SharePoint > Exception while creating Web Application : Failed to call GetTypes on assembly Microsoft.Office.InfoPath.Server

Exception while creating Web Application : Failed to call GetTypes on assembly Microsoft.Office.InfoPath.Server

I have SharePoint Server 2010 and Office 2013 Installed on my machine , I installed office after SharePoint Server 2010 installation but after Installation of Office 2013, Creation of web application in SharePoint Server 2010 starts throwing exception : Provisioning of the web application ‘Web app – Port’  has encountered the following error: Microsoft.SharePoint.Upgrade.SPUpgradeException: Failed to call GetTypes on assembly Microsoft.Office.InfoPath.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c. Could not load file or assembly ‘Microsoft.Office.InfoPath, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c’ or one of its dependencies. The system cannot find the file specified.

After some searching on Internet ‘Googling’  , i got the solution , The solution to the problem is to Downgrade ‘Info Path’ or to remove Info Path. Perhaps this is not the desired way to come up with some proper solution but lets hope Microsoft will come up with appropriate fix to this.

I uninstalled Info Path and it worked for me. Now SharePoint 2010 is working as expected.

Advertisements
  1. k0n4n
    November 12, 2013 at 8:57 pm

    Thank you, you solve my question 😀

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: